Welcome new user! You can search existing questions and answers without registering, but please register to post new questions and receive answers.
Welcome to JeVois Tech Zone, where you can ask questions and receive answers from other members of the community.

Is it possible this broke again in 1.7.0? Unable to install jevois-sdk on 16.04.1 - Ubuntu

0 votes
I'm still having problems installing jevois-sdk > 1.7.0 similar to the original questions here.

One thing I did screw up was first accidentally starting down the Ubuntu 17.10 path and execute sudo add-apt-repository "deb https://jevois.usc.edu/apt artful main", but then I have followed the instructions for 16.04 multiple times. History from latest attempt is below.

Thanks,

Brad

bradley@bradley-ThinkPad-Yoga-14:~$ uname -a
Linux bradley-ThinkPad-Yoga-14 4.13.0-32-generic #35~16.04.1-Ubuntu SMP Thu Jan 25 10:13:43 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
bradley@bradley-ThinkPad-Yoga-14:~$ sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys DD24C027
[sudo] password for bradley:
Executing: /tmp/tmp.RA4edSXgNH/gpg.1.sh --keyserver
keyserver.ubuntu.com
--recv-keys
DD24C027
gpg: requesting key DD24C027 from hkp server keyserver.ubuntu.com
gpg: key C25E5DDA: "Laurent Itti <jevois.org@gmail.com>" not changed
gpg: Total number processed: 1
gpg:              unchanged: 1
bradley@bradley-ThinkPad-Yoga-14:~$ sudo add-apt-repository "deb https://jevois.usc.edu/apt xenial main"
bradley@bradley-ThinkPad-Yoga-14:~$
bradley@bradley-ThinkPad-Yoga-14:~$ sudo add-apt-repository -y ppa:ubuntu-toolchain-r/test
gpg: keyring `/tmp/tmp833470is/secring.gpg' created
gpg: keyring `/tmp/tmp833470is/pubring.gpg' created
gpg: requesting key BA9EF27F from hkp server keyserver.ubuntu.com
gpg: /tmp/tmp833470is/trustdb.gpg: trustdb created
gpg: key BA9EF27F: public key "Launchpad Toolchain builds" imported
gpg: Total number processed: 1
gpg:               imported: 1  (RSA: 1)
OK
bradley@bradley-ThinkPad-Yoga-14:~$ sudo apt update
Hit:1 http://security.ubuntu.com/ubuntu xenial-security InRelease
Hit:2 http://us.archive.ubuntu.com/ubuntu xenial InRelease                     
Hit:3 http://packages.ros.org/ros/ubuntu xenial InRelease                      
Hit:4 http://us.archive.ubuntu.com/ubuntu xenial-updates InRelease             
Hit:5 http://us.archive.ubuntu.com/ubuntu xenial-backports InRelease    
Hit:6 http://ppa.launchpad.net/ubuntu-toolchain-r/test/ubuntu xenial InRelease
Ign:7 https://dl.bintray.com/resin-io/debian stable InRelease
Get:8 https://dl.bintray.com/resin-io/debian stable Release [1,878 B]
Hit:9 https://jevois.usc.edu/apt artful InRelease
Hit:8 https://dl.bintray.com/resin-io/debian stable Release
Hit:10 https://jevois.usc.edu/apt xenial InRelease      
Reading package lists... Done
Building dependency tree       
Reading state information... Done
All packages are up to date.
bradley@bradley-ThinkPad-Yoga-14:~$ sudo apt upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
bradley@bradley-ThinkPad-Yoga-14:~$ sudo apt autoremove
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
bradley@bradley-ThinkPad-Yoga-14:~$ sudo apt install jevois-sdk-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 jevois-sdk-dev : Depends: jevois-sdk (>= 1.7.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
bradley@bradley-ThinkPad-Yoga-14:~$
asked Feb 12 in Programmer Questions by vatbrain (120 points)

1 Answer

0 votes
Let me check, this is detected by cmake and cpack now, but it is possible that python3.6 was installed somehow on the ubuntu 16.04 VM that was used to create the debs. I will run it again on a fresh VM and create new debs.
answered Feb 13 by JeVois (25,740 points)
...