Welcome new user! You can search existing questions and answers without registering, but please register to post new questions and receive answers. Note that due to large amounts of spam attempts, your first three posts will be manually moderated, so please be patient.

Issue in running custom Tensorflow network

0 votes

Hi, 

I am trying to run a custom tensorflow network on Jevois but it is giving me a hard time. The following is what I have done so far:

I am using Vgg16 network from https://github.com/qubvel/classification_models and have trained it on my own dataset and then saved the model in a h5 file.

I then converted the h5 file to tflite file to deploy it on Jevois.

Following the Jevois custom training tutorial, I have put the tflite file and labels.txt file in Jevois sd card on this path: /share/tensorflow/recycle

Now when I connect the camera and select the TensorFlow easy module in Jevois-inventor, it shows the picture and hangs there and then gives error saying "Malformed Jevois Software version from Jevois Camera   Disconnecting..." and then the software exits. I don't know what could be the problem. The input for the network is 224 x 224 so I have set it using foa. The tflite file I got is about 65MB in size and I saw some other tflite files they have a smaller size may be that could be the problem? I would really appreciate if somebody could guide me in the right direction. Thanks.

asked Jan 25 in Programmer Questions by haseebtehsin (120 points)

1 Answer

0 votes
VGG-16 may indeed be too big for JeVois.

Can you email us your model files and params.cfg to jevois.org@gmail.com? We can try to load it here with a USB-to-serial diagnostic cable plugged in and we can tell you if the camera runs out of memory.
answered Jan 28 by JeVois (46,200 points)
...